如何安装最新的Graphviz?

Modified on: Sat, 09 Jun 2018 15:54:53 +0800

默认的graphviz包已经过时了。所以我尝试从以下网站获取最新的软件包:http://www.graphviz.org/Download_linux_ubuntu.php

尝试安装libgraphviz4它抱怨与libcdt4发生冲突
所以我apt-get删除它,然后它抱怨与libpathplan4发生冲突
所以我apt-get删除它,然后它抱怨与libxdot4发生冲突
所以我倾向于删除它,然后抱怨...

Dependency is not satisfiable: libgd2-noxpm (>=2.0.36~rc1~dfsg)|libgd2-xpm (>=2.0.36~rc1~dfsg)

我能找到的最近的包是libgd2-xpm-dev 2.1.0-2
安装不能解决问题。

如何安装?

标记为“重复问题”的解决方案无效。
尝试安装软件包失败,甚至在循环中建议事情。
我不清楚为什么libgd2-xpm-dev 2.1.0-2无论如何都不满足依赖。

$ sudo apt-get install libgd2-xpm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgd2-xpm is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libgd2-xpm:i386

E: Package 'libgd2-xpm' has no installation candidate

$ sudo apt-get install libgd2-xpm:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libgd2-xpm:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libgd2-xpm

E: Package 'libgd2-xpm:i386' has no installation candidate

最佳答案

我认为您正在尝试使用sudo dpkg -i package来安装该软件包,这通常会导致软件包依赖性问题,所以我建议使用gdebi。如果您有任何问题包删除它。您可以使用sudo apt-get check进行检查。现在开始营业了:

sudo apt-get install gdebi-core

我们准备好了gdebi。现在,如果您使用64位系统,您可能希望安装64位软件包,同样使用32位软件。

现在这里有趣的东西......

sudo gdebi graphviz_2.37.20140208.0545-1\~saucy_amd64.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
This package is uninstallable
Dependency is not satisfiable: libgd2-noxpm (>= 2.0.36~rc1~dfsg)|libgd2-xpm (>= 2.0.36~rc1~dfsg)

这是你停下来的地方。原因是稳定的包依赖于Debian丢弃的包,ergo Ubuntu 13.10:

libgd2 (2.0.36~rc1~dfsg-6.1) unstable; urgency=low

  * Non-maintainer upload.
  * Support multi-arch: (closes: #652496)
    - Mark libgd2-xpm, libgd2-noxpm, libgd2-xpm-dev and libgd2-noxpm-dev
as same.
- Adjust d-shlibs and dh-buildinfo build-dependency. * Drop .la files. -- Bastian Blank Sun, 13 May 2012 09:16:37 +0000

这些是graphviz的依赖项,因此它们应分别将它们更改为libgd2-xpm-devlibgd2-noxpm-dev。如果是这种情况,您应该下载最新版本,而不是2.38或更高版本,其中包含正确的依赖项。

作者:,Braiam

相关问答

添加新评论