CentOS 6.6(最终版) - 百胜内核升级麻烦

Modified on: Thu, 26 Sep 2019 07:40:02 +0800

幸福大家,

我是SysAdmin Junior管理3 CentOS虚拟(Web)服务器,
今天早上我遇到了包管理器yum的麻烦。像往常一样操作,今天早上我运行命令yum update &amp;&amp; yum upgrade,对其中一个CentOS(年轻人)没问题,一切都很好。但是在“最老的”2台服务器上(不是那么老,从1。5年开始运行,但可能并不出众)似乎升级内核存在一些问题,我用google搜索,看起来这只是我的问题,跟着控制台输出:< / p>

# yum update && yum upgrade


Finished Dependency Resolution
Error: Package: kernel-2.6.32-573.1.1.el6.x86_64 (centos6_x86_update)
       Requires: dracut-kernel >= 004-388.el6
       Installed: dracut-kernel-004-356.el6_6.3.noarch (@centos6_x86_update)
           dracut-kernel = 004-356.el6_6.3
       Available: dracut-kernel-004-336.el6.noarch (centos6_x86_update)
           dracut-kernel = 004-336.el6
       Available: dracut-kernel-004-336.el6_5.2.noarch (centos6_x86_update)
           dracut-kernel = 004-336.el6_5.2
       Available: dracut-kernel-004-356.el6.noarch (base)
           dracut-kernel = 004-356.el6
       Available: dracut-kernel-004-356.el6_6.1.noarch (centos6_x86_update)
           dracut-kernel = 004-356.el6_6.1
       Available: dracut-kernel-004-356.el6_6.2.noarch (centos6_x86_update)
           dracut-kernel = 004-356.el6_6.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

我已经阅读了文档,以便试着理解上面提到的建议命令会做什么,因为它对我来说似乎没什么危险,我已经试过了,但实际上并没有改变。问题仍然存在......

有人可以给我一个推力吗?

提前感谢

风会对你有利

作者:,lese

最佳答案

看起来像镜像或yum-cache的问题,因为dracut-kernel 004-388.el6应该可用,至少对我来说是这样的:

============================================================================================================= Package Arch Version Repository Size ============================================================================================================= Installing: dracut-kernel noarch 004-388.el6 base 26 k

清理您的yum缓存,然后重试:

yum clean all &amp;&amp; yum update

P上。 S:

yum update &amp;&amp; yum upgrade没有意义,这些命令之间的唯一区别是隐含的obsoletes标志。这不像apt-get(apt-get update &amp;&amp; apt-get upgrade)。

作者:etagenklo

相关问答

添加新评论