LXC对VPS托管是否足够安全?

Modified on: Sat, 14 Sep 2019 08:20:02 +0800

现在我正在使用Linux VServer进行VPS托管。但它缺少我需要的一些功能(例如cpu使用虚拟化,客人配额支持等)所以我正在考虑切换到OpenVZ或直接转换到LXC。我在某处阅读LXC还不被认为是安全的(ex http://en.gentoo -wiki.com/wiki/LXC#MAJOR_Temporary_Problems_with_LXC_-_READ_THIS) - 这仍然是真的吗?因为我不知道管理客人的人我真的需要照顾安全。

作者:,gucki

最佳答案

在撰写本文时,仍然存在/ proc过滤的关键问题。它们应该在Linux Kernel 3.6或更高版本中解决。

由于我遇到了与您相同的问题,我已经做了一些调查,而且我尚未确信LXC是Linux VServer的替代品

如果您决定不切换到LXC 查看Linux Vserver的cgroup支持,它基于与LXC相同的代码,可能是您的设置选项。

作者:tex

相关问答

添加新评论