无法安装fastcgi ubuntu服务器:包libapache2-mod-fastcgi不可用

Modified on: Mon, 09 Sep 2019 06:40:02 +0800

当我尝试在ubuntu服务器12.04中安装fastcgi时,我收到以下错误:

sudo apt-get install libapache2-mod-fastcgi


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libapache2-mod-fastcgi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libapache2-mod-fastcgi' has no installation candidate

任何解决方案?

作者:Khaled,brpaz

最佳答案

libapache2-mod-fastcgi可以在multiverse。如果我没记错的话,Ubuntu的默认安装用来不启用 multiverse (但现在应该这样)。

也许在您的系统上已禁用它,您必须将其添加到存储库列表中(就像编辑/etc/apt/sources.list并附加 multiverse一样简单 main 之后或使用图形数据包管理器。)

Debian将libapache2-mod-fastcgi作为非自由的一部分发布,因此这可能是许可证问题。

作者:Alex

相关问答

添加新评论