如何在Ubuntu 16.04中安装google-talkplugin deb

Modified on: Sat, 09 Jun 2018 10:36:53 +0800

我需要在Ubuntu 16.04中安装此插件:

https://www.google.com/tools/dlpage/hangoutplugin

在以前的Ubuntu版本中,我轻松安装了这个插件,但我无法通过其新的GUI软件管理器在16.04上安装它。

我提交了一个关于此的错误:
https://bugs.launchpad.net/ubuntu/+source/gnome-software/+错误/ 1573408

请建议解决方法。

作者:,Lonnie Best

最佳答案

我可以使用命令行安装插件,如下所示:

sudo dpkg -i google-talkplugin_current_amd64.deb

这产生了这个:

Selecting previously unselected package google-talkplugin.
(Reading database ... 196768 files and directories currently installed.)
Preparing to unpack google-talkplugin_current_amd64.deb ...
Unpacking google-talkplugin (5.41.0.0-1) ...
Setting up google-talkplugin (5.41.0.0-1) ...

在此之后,我重启了Firefox。我去Gmail打电话,点击“允许”按钮(在Firefox顶部提示 - 在地址栏下方),它就可以了。

然而,在安装之后,我再也无法sudo apt-get update

sudo apt-get update
W: http://dl.google.com/linux/talkplugin/deb/dists/stable/Release.gpg: Signature by key ***************omitted****************** uses weak digest
algorithm (SHA1)
E: Failed to fetch http://dl.google.com/linux/talkplugin/deb/dists/stable/Release  No Hash entry in Release file /var/lib/apt/lists/partial/dl.google.com_linux_talkplugin_deb_dists_stable_Release which is considered strong enough for security purposes

现在,我通过取消选中这个来禁用该存储库:

以上步骤是我对此错误的弱解决方法:
https://bugs.launchpad.net/ubuntu/+source/apt / +错误/ 1562733

有人告诉我,在修复存储库之前我可以忽略该错误(而不是像上面那样禁用它)。但是,我没有发现这种情况;似乎如果在sudo apt-get更新期间出现一次故障,则成功的存储库(在该错误之后 - 没有问题的那些)不会受到影响(因此它最终会阻止您完全更新计算机的能力)。

如果我正确理解了错误,Google似乎需要修复他们的存储库以遵守Debian / Ubuntu(新的)更高的安全性要求来签署包。

要鼓励Google解决此问题,请参阅此处:
https://wiki.debian.org/Teams/Apt/Sha1Removal

作者:,Lonnie Best

相关问答

添加新评论