如何让Calibri字体很好地显示[重复]

Modified on: Thu, 14 Jun 2018 12:14:23 +0800
    

这个问题已经有了答案:

    

            
  •             LibreOffice下ttf字体呈现的问题
                                        3个答案
                    跨度>
            
  •     

    

我安装了Calibri,因为它是M $ Office的默认字体,所以很多客户都使用这种字体向我发送文件。

但它显示没有抗锯齿,这是可怕的。就像再次使用Windoze机器一样:-O

似乎只发生在小尺寸上;它以更大的尺寸进行抗锯齿处理。我可以禁用它吗?

编辑:

我的/etc/fonts/config.avail/10-antialias.conf包含

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!--  Use the Antialiasing -->
  <match target="font">
    <edit name="antialias" mode="assign"><bool>true</bool></edit>
  </match>
</fontconfig>

% fc-match calibri          
calibri.ttf: "Calibri" "Regular"
作者:,artfulrobot

最佳答案

MS-C字体嵌入位图

对于这个答案的评论,MS C字体(Cambria,Calibri ......)最常见的问题是它们使用嵌入式位图。要更改它,请禁用它们。在

  1. ~/.fonts.conf
  2. 14.04中的
  3. ~/.config/font-manager/local.conf; Font Manager保留管理~/.fonts.conf文件的权利,谢谢@Alain)
  4. ~/.config/fontconfig/fonts.conf(根据@SpinUp和@ Glutamine的评论)
    您需要添加此XML代码段:
  5. 醇>
    <!-- disable embedded bitmaps in fonts to fix Calibri, Cambria, etc. -->
    <match target="font">
       <edit mode="assign" name="embeddedbitmap"><bool>false</bool></edit>
    </match>
    

    抗锯齿切换

    你应该能够在/etc/fonts/conf.avail/中切换配置,即抗锯齿,而不是自动提示。怎么做:在true中将false更改为10-antialias.conf,反之亦然,你切换了抗锯齿,可以看看是否有帮助。类似于10-autohinting.conf。这会切换所有字体AFAIR的设置,所以只要看看它是否有助于您的情况,您就会知道问题是否存在。

    注意:只读文件需要sudo进行修改(或者需要在写入之前写入),所以无论编辑是什么(我的vim

    缓存重建和字体堆栈更改

    此外,经常建议的字体解决方案是重建缓存:sudo fc-cache -v -f。特别是如果您对字体堆栈进行了更改(安装了新字体,删除,移动等)。

    此外,fc-match calibri显示什么?为什么我要问:在我的情况下很好地显示Calibri,我不得不回到DejaVu Sans,否则我有一个缺少连线问题:见我的Calibri问题在这里。我通过删除Calibri常规字体文件(.ttf)来做到这一点。所以,对我来说,fc-match输出如下:

    ➜  ~  fc-match calibri
    DejaVuSans.ttf: "DejaVu Sans" "Book"
    

相关问答

添加新评论