加载共享库时,GParted没有工作错误:libgtkmm-2.4.so.1

Modified on: Thu, 14 Jun 2018 11:05:23 +0800

我无法运行gparted。

我已经清除并重新安装,错误仍然存​​在。

这是在终端

中运行sudo gparted的输出

$ sudo gparted
/usr/sbin/gpartedbin: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

我尝试安装libgtkmm-2.4,我得到了这个:

$ sudo apt-get install libgtkmm-2.4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libgtkmm-2.4-dev' for regex 'libgtkmm-2.4'
Note, selecting 'libgtkmm-2.4-1c2a' for regex 'libgtkmm-2.4'
Note, selecting 'libgtkmm-2.4-doc' for regex 'libgtkmm-2.4'
Note, selecting 'libgtkmm-2.4-1v5' for regex 'libgtkmm-2.4'
Note, selecting 'libgtkmm-2.4-dbg' for regex 'libgtkmm-2.4'
libgtkmm-2.4-1v5 is already the newest version.
The following extra packages will be installed:
  debhelper gir1.2-gtk-2.0 gtkmm-documentation libatk1.0-dev libatkmm-1.6-dev
  libcairo-script-interpreter2 libcairo2-dev libcairomm-1.0-dev
  libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
  libglibmm-2.4-dev libglibmm-2.4-doc libgtk2.0-dev libgtkmm-3.0-doc
  libharfbuzz-dev libharfbuzz-gobject0 libice-dev libmail-sendmail-perl
  libpango1.0-dev libpangomm-1.4-dev libpcre3-dev libpcre32-3 libpcrecpp0v5
  libpixman-1-dev libpng12-dev libpthread-stubs0-dev libsigc++-2.0-dev
  libsm-dev libsys-hostname-long-perl libx11-dev libx11-doc libxau-dev
  libxcb-render0-dev libxcb-shm0-dev libxcb1-dev libxcomposite-dev
  libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev
  libxft-dev libxi-dev libxinerama-dev libxml2-utils libxrandr-dev
  libxrender-dev po-debconf x11proto-composite-dev x11proto-core-dev
  x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev
  x11proto-randr-dev x11proto-render-dev x11proto-xext-dev
  x11proto-xinerama-dev xorg-sgml-doctools xtrans-dev
Suggested packages:
  dh-make libatkmm-1.6-doc libcairo2-doc libcairomm-1.0-doc libglib2.0-doc
  libgtkmm-3.0-dev libgtk2.0-doc libice-doc libpango1.0-doc libsigc++-2.0-doc
  libsm-doc libxcb-doc libxext-doc libmail-box-perl
The following NEW packages will be installed
  debhelper gir1.2-gtk-2.0 gtkmm-documentation libatk1.0-dev libatkmm-1.6-dev
  libcairo-script-interpreter2 libcairo2-dev libcairomm-1.0-dev
  libfontconfig1-dev libfreetype6-dev libgdk-pixbuf2.0-dev libglib2.0-dev
  libglibmm-2.4-dev libglibmm-2.4-doc libgtk2.0-dev libgtkmm-2.4-dbg
  libgtkmm-2.4-dev libgtkmm-2.4-doc libgtkmm-3.0-doc libharfbuzz-dev
  libharfbuzz-gobject0 libice-dev libmail-sendmail-perl libpango1.0-dev
  libpangomm-1.4-dev libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev
  libpng12-dev libpthread-stubs0-dev libsigc++-2.0-dev libsm-dev
  libsys-hostname-long-perl libx11-dev libx11-doc libxau-dev
  libxcb-render0-dev libxcb-shm0-dev libxcb1-dev libxcomposite-dev
  libxcursor-dev libxdamage-dev libxdmcp-dev libxext-dev libxfixes-dev
  libxft-dev libxi-dev libxinerama-dev libxml2-utils libxrandr-dev
  libxrender-dev po-debconf x11proto-composite-dev x11proto-core-dev
  x11proto-damage-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev
  x11proto-randr-dev x11proto-render-dev x11proto-xext-dev
  x11proto-xinerama-dev xorg-sgml-doctools xtrans-dev
0 to upgrade, 65 to newly install, 0 to remove and 0 not to upgrade.
Need to get 46.4 MB of archives.
After this operation, 332 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

这说它已经安装但是它想要安装一大堆具有依赖性的附加功能,我不愿意这样做,因为它说它所抱怨的特定包已经安装了所以我的怀疑这些额外内容会解决任何问题。

我该怎么办?

最佳答案

尝试在此命令中删除这些软件包gparted libatkmm-1.6-1v5 libgtkmm-2.4-1v5 libgtkmm-3.0-1v5 pavucontrol

sudo apt-get remove gparted libatkmm-1.6-1v5 libgtkmm-2.4-1v5 libgtkmm-3.0-1v5 pavucontrol 

然后安装ubuntu-desktop如果删除它。

sudo apt-get install ubuntu-desktop gparted libatkmm-1.6-1v5 libgtkmm-2.4-1v5 libgtkmm-3.0-1v5 pavucontrol
作者:TJK,Neil

相关问答

添加新评论