如何安装12.10的开发工具?

Modified on: Thu, 14 Jun 2018 05:54:53 +0800

我有一个源tarball:ap-kernelmodule-1.0.14-13.tar.gz
我必须编译一个内核模块,并被指示为我的Ubuntu版本(12.10)安装开发工具。
格式为:sudo apt-get install linux-headers-$(uname -r) build-essential

问题#1:什么是uname

(当我安装Ubuntu时,我输入sharon作为我的名字,这也是我的帐户名。每当我打开终端窗口时,会出现sharon@sharon:字样)
根据格式,我应该输入:

sudo apt-get install linux-headers-$(sharon -r) build-essential

sudo apt-get install linux-headers-$sharon -r build-essential

问题2:上述哪一项是正确的?

(我是Linux和Ubuntu的新手;因此感谢详细说明)

作者:qbi,n00b

最佳答案

不要复制我的命令,你必须输入它们并使用tab键,因为我的内核可能与你的不同。我通过游戏解释游戏:

打开终端并输入:

sudo apt-get update

此更新为您的计算机提供了您可能需要的文件。但没有文件下载,只有可以下载的信息。如果您没有先执行此操作,则可能没有安全更新或最新版本软件的最新链接。

在您键入时,按选项卡键,完成命令。开始输入将安装build-essential的命令。一旦你到达这个远处:

sudo apt-get install linux-headers-

应该出现的下一部分将是您的Linux内核。所以打开另一个终端并键入:

uname -r

你应该看到这样的东西:

3.2.0-23-generic

现在返回另一个终端并按Tab键作为类型。你应该看到你的内核弹出。选择那个。

3.2.0-23-generic

现在输入一个空格并添加build-essential(不要忘记使用你的标签完成)。

sudo apt-get install linux-headers-3.2.0-23-generic

现在点击回车,将下载文件,帮助您编译代码。

作者:cxx6xxc

相关问答

添加新评论