安装parallels工具后Unity崩溃(Ubuntu 16.04)

Modified on: Sat, 09 Jun 2018 07:27:53 +0800

我已经在我的MacBook Pro上下载并安装了Parallels 11的Ubuntu 16.04。

安装很顺利,重启后我可以登录并使用图形界面而不会出现问题。

无论如何,分辨率很低,显示宽高比错误,所以我像往常一样安装Parallels Tools来解决这些小问题并激活一些相似的功能。

在我安装了parallels工具后,我重新启动了我的虚拟机,一切似乎都很好(登录和统一工作完美无瑕),但在我重新启动后,每次登录时团结都会崩溃。

我知道这个问题(或类似问题)已经在某种程度上解决了:

  1. Unity无法加载,没有启动器,没有出现短划线< / A>
  2. Parallels(工具)9&amp; 14.04
  3. 在Ubuntu 14.04中安装Parallels Tools后,Unity崩溃了
  4. 醇>

    但这些方法都不适用于我的情况。

    特别是:

    1. 1中接受的解决方案无法正常工作,因为当我从命令行启动ccsm时,它不会出现在图形界面中。
    2. 阅读2中的唯一答案我意识到我根本没有xorg.conf(现在似乎是默认行为),所以我尝试了sudo /etc/init.d/lightdm stop然后X -configure然后重新安装Parallels Tools而没有运气! (注意:我必须在干净安装时启动这些命令,因为我第一次安装Parallels Tools后lightdm没有正常停止。)
    3. 3中使用建议的解决方案(即使在如上所述生成xorg.conf之后),我使用gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins表示DBUS无法连接。
    4. 醇>

      有什么想法吗?

作者:Community,Sirion

最佳答案

快速而肮脏的工作

免责声明:我通过试验和错误找到了这个“解决方案”,因此我不能保证它是安全的。使用它需要您自担风险。

背景:当安装Parallels Tools时,它会在/usr/lib/compiz/下复制一堆带有此模式的文件libprlcompiz_*_*_*_*.so(用数字代替*)。这些是统一插件,并且看起来,当Unity加载时,也会加载此插件的最新版本。

现在,在我的情况下,Unity会尝试加载libprlcompiz_0_9_12_2.so,这会导致错误:Segmentation fault (core dumped)

所以我的目的是重命名这个文件,并希望以前的插件版本没有错误(即libprlcompiz_0_9_12_1.so)。打开终端并:

sudo mv /usr/lib/compiz/libprlcompiz_0_9_12_2.so /usr/lib/compiz/libprlcompiz_0_9_12_2.so.backup
reboot

现在登录后一切正常。

登录后我仍然有三个相关的进程出现在统一边栏中(带有问号图标),一段时间后会消失。

请告诉我这是否适合您。

作者:Sirion

相关问答

添加新评论