iPod Touch(iPhone)的固件更新?

Modified on: Thu, 14 Jun 2018 03:54:53 +0800

我需要在Ubuntu中更新我的iPod Touch(iPhone)的固件,因为我已经越狱了iPod Touch我需要iTunes来安装应用程序,但遗憾的是还没有找到任何方法在Ubuntu中这样做。我知道可以使用VirtualBoxWine,但在大多数情况下iTunes仍然不想使用Wine对于VirtualBox,我需要再次安装几个月前我从中切换到Ubuntu的Windows,并且不想再回到它。

在这种情况下,拥有iPod Touch(iPhone)的Linux用户会做些什么?

任何解决问题的建议都会很高兴。

最后,Apple开发iTunes for Linux OS需要多长时间?

最佳答案

虽然目前某些旧版本的iTunes可以与Wine(或Crossover)配合使用,但它们不能用于更新或同步较新的iPod

原因是Wine缺少Windows USB设备驱动程序的处理程序,而iPod则充当自定义USB设备。这与需要特殊密钥加密狗的软件(还)在Wine中不起作用的原因相同。有一些初步的补丁可用于此,您可以在Wine wiki上阅读更多历史记录,但不要指望任何工作

目前在Wine中工作的唯一iPod是非常老的iPod,它们可以作为简单的USB大容量存储设备。即使这样,你仍然需要找一个更老的,有效的iTunes。

由于Wine中的这个问题,要进行固件升级,您需要使用Virtualbox或VMware设置虚拟机,或者更简单地说,借用其他人的计算机。


相关问答

添加新评论