检查Code :: Blocks中的GCC编译器版本[关闭]

Modified on: Sat, 02 Feb 2019 13:40:03 +0800

如何在Code :: Blocks中检查我使用的是哪个版本的GCC编译器?

最佳答案

运行gcc --version,结果将是这样的:

gcc (GCC) 4.4.0
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

如果这不起作用,您可能没有正确地在PATH中设置编译器(我相信这在Windows上使用MinGW时很常见),在这种情况下,您可以先检查编译器的位置通过在Code :: Blocks:

中执行以下操作来定位

  • 菜单栏Settings - > Compiler and Debugger
  • 选择GNU GCC Compiler
  • 选择Toolchain executables选项卡

然后,使用命令行,移动到给定的目录,然后进入bin子目录,然后尝试从那里运行gcc --version

作者:DMA57361

相关问答

添加新评论