修改gedit语法高亮显示文件

Modified on: Sat, 28 Jul 2018 11:20:03 +0800

我正在尝试更改Gedit中的突出显示文件。我修改了文件/usr/share/gtksourceview-3.0/language-specs/fortran.lang,因为我想更改编辑器将语句作为注释的情况。我遇到的问题是,当我选择新的突出显示方案时,没有任何突出显示,它只是保持纯文本。

使用su权限打开文件fortran.lang,我只是将所有内容复制粘贴到新的Gedit文件中,然后将其保存为fortran_enhanced.lang在同一文件夹中。我对原始文件所做的更改包括:

原始fortran.lang文件:

<language id="fortran" _name="Fortran 95" version="2.0" _section="Sources">
  <metadata>
    <property name="mimetypes">text/x-fortran</property>
    <property name="globs">*.f;*.f90;*.f95;*.for</property>
    <property name="line-comment-start">!</property>
  </metadata>
  <styles>
    <style id="comment" _name="Comment" map-to="def:comment"/>
    <style id="floating-point" _name="Floating Point" map-to="def:floating-point"/>
    <style id="keyword" _name="Keyword" map-to="def:keyword"/>
    <style id="intrinsic" _name="Intrinsic function" map-to="def:builtin"/>
    <style id="boz-literal" _name="BOZ Literal" map-to="def:base-n-integer"/>
    <style id="decimal" _name="Decimal" map-to="def:decimal"/>
    <style id="type" _name="Data Type" map-to="def:type"/>
  </styles>
  <default-regex-options case-sensitive="false"/>
  <definitions>
    <!-- Note: contains an hack to avoid considering ^COMMON a comment -->
    <context id="line-comment" style-ref="comment" end-at-line-end="true" class="comment" class-disabled="no-spell-check">
      <start>!|(^[Cc](\b|[^OoAaYy]))</start>
      <include>
        <context ref="def:escape"/>
        <context ref="def:in-line-comment"/>
      </include>
    </context>
(...)

修改了fortran_enhanced.lang文件:

                     <!-- Note: changed language id and name -->
<language id="fortran_enhanced" _name="Fortran 95 2.0" version="2.0" _section="Sources">
  <metadata>
    <property name="mimetypes">text/x-fortran</property>
                     <!-- Note: removed *.f and *.for from file extensions -->
    <property name="globs">*.f90;*.f95;</property>
    <property name="line-comment-start">!</property>
  </metadata>
  <styles>
    <style id="comment" _name="Comment" map-to="def:comment"/>
    <style id="floating-point" _name="Floating Point" map-to="def:floating-point"/>
    <style id="keyword" _name="Keyword" map-to="def:keyword"/>
    <style id="intrinsic" _name="Intrinsic function" map-to="def:builtin"/>
    <style id="boz-literal" _name="BOZ Literal" map-to="def:base-n-integer"/>
    <style id="decimal" _name="Decimal" map-to="def:decimal"/>
    <style id="type" _name="Data Type" map-to="def:type"/>
  </styles>
  <default-regex-options case-sensitive="false"/>
  <definitions>
                     <!-- Note: I want comments only beginning with !, not C -->
    <context id="line-comment" style-ref="comment" end-at-line-end="true" class="comment" class-disabled="no-spell-check">
      <start>!</start>
      <include>
        <context ref="def:escape"/>
        <context ref="def:in-line-comment"/>
      </include>
    </context>
(...)

我已阅读此问题[自定义gedit语法突出显示傻瓜?我尝试用

创建新的fortran_enhanced.lang文件

$ cd /usr/share/gtksourceview-3.0/language-specs
$ sudo chmod 0644 fortran_enhanced.lang

但它没有任何区别。

我必须说我之前从未做过这样的事情,我甚至不理解大部分的语言文件,因此我对所有批评都持开放态度,因为我纯粹是凭直觉引导的。

先谢谢你!

最佳答案

我想我发现你出了什么问题:

解决方案

很好,你更改了id标记中的_name(和&lt;language ...&gt;)。毕竟这是你创建的一个新的突出显示方案。

但是,您必须更改文件中使用此ID的其他位置。进一步在语言定义中(在问题的引用中省略),你会发现:

  

&lt;context id="fortran" class="no-spell-check"&gt;

显然,你必须有一个与你的语言具有相同id的上下文,包括/引用所有使用的上下文定义,以便gedit / GtkSourceView在选择特定方案时使用它。

我是如何找到它的

我根本不是这方面的专家。我所有的资格都是因为我之前看过XML文件;)所以我只能做出“受过教育的”猜测。

从终端窗口启动gedit时显示的警告是什么?

  

(gedit:6786):GtkSourceView-WARNING **:无法加载
  '/usr/local/share/gtksourceview-3.0/language-specs/frtrn.lang':
  缺少主要语言定义(id =“frtrn”。)

(我在测试时使用“ frtrn ”作为ID,名称和文件扩展名,您应该使用“ fortran_enhanced ”获得相同的警告)

这使我怀疑在文件的其余部分中搜索原始ID。在尝试上述解决方案后,我还找到了以下行来支持我的解释:

  

[定义]
  在这里,我们应该定义一个主要的上下文,我们输入的主要上下文
  文件的开头:为此我们使用带有id的标签
  等于元素的id
  [...]

来自GtkSourceView文档中的语言定义文件教程

作者:zpea

相关问答

添加新评论