如何在Arch Linux上使用A2DP配置文件防止蓝牙音频跳过?

Modified on: Thu, 12 Jul 2018 22:12:00 +0800

在T430上使用pulseaudio和Arch Linux将音频流式传输到我的蓝牙音箱(Sony SRS-X3)时,我遇到了相当沉重的音频跳跃。我认为这与已知的bug有关[1]。扬声器与Android完美配合。

$ sudo lspci -nnk | grep -iA2 net  
> Network controller [0280]: Intel Corporation Centrino Ultimate-N 6300 [8086:4238] (rev 3e)
> Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN [8086:1111]
> Kernel driver in use: iwlwifi

$ sudo lsusb | grep Blue
> 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]

有没有人知道如何减少/防止跳绳?我们也非常感谢帮助我理解这个问题的信息。


我怀疑这与干扰WiFi有关。 WiFi关闭或深夜(流量较少)的跳频较少。 Android如何处理这个?我的研究发现了Linux频率代理[2]。它实施了吗?

[1] https://bugs.launchpad.net/ubuntu / +源/的pulseaudio / +错误/ 405294

[2] https://wireless.wiki.kernel.org/en/developers / frequencybroker

作者:,sedot

最佳答案

可能有助于禁用iwlwifi模块的蓝牙共存参数,以查看条件是否有所改善。打开终端窗口并输入

echo "options iwlwifi bt_coex_active=0" | sudo tee -a /etc/modprobe.d/iwlwifi.conf

重新启动

作者:Jeremy31

相关问答

添加新评论