有没有人在Ubuntu 14.04.3 LTS x86_64上成功安装了CUDA 7.5?

Modified on: Mon, 25 Jun 2018 13:47:23 +0800

我的工作站有两个GPU(Quadro K5200和Quadro K2200),安装了最新的NVIDIA驱动程序(版本:352.41)。从cuda-repo-ubuntu1404-7-5-local_7.5-18_amd64.deb 后“nofollow noreferrer”> CUDA 7.5下载,我尝试安装它,但结果如下:

root@P700-Bruce:/home/bruce/Downloads# sudo apt-get install cuda
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cuda : Depends: cuda-7-5 (= 7.5-18) but it is not going to be installed
 unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                        Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

我尝试过这个解决方案:

  1. root@P700-Bruce:/home/bruce/Downloads# sudo apt-get install cuda Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: cuda : Depends: cuda-7-5 (= 7.5-18) but it is not going to be installed unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed Depends: libcheese7 (>= 3.0.1) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. #remove old nvidia-cuda packages
  2. 安装未满足的依赖项:

    root@P700-Bruce:/home/bruce/Downloads# apt-get install cuda-7-5
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     cuda-7-5 : Depends: cuda-toolkit-7-5 (= 7.5-18) but it is not going to be installed
                Depends: cuda-runtime-7-5 (= 7.5-18) but it is not going to be installed
     unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                            Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    
    root@P700-Bruce:/home/bruce/Downloads# apt-get install cuda-toolkit-7-5
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     cuda-toolkit-7-5 : Depends: cuda-core-7-5 (= 7.5-18) but it is not going to be installed
                        Depends: cuda-command-line-tools-7-5 (= 7.5-18) but it is not going to be installed
                        Depends: cuda-samples-7-5 (= 7.5-18) but it is not going to be installed
                        Depends: cuda-documentation-7-5 (= 7.5-18) but it is not going to be installed
                        Depends: cuda-visual-tools-7-5 (= 7.5-18) but it is not going to be installed
     unity-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed
                            Depends: libcheese7 (>= 3.0.1) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    
  3. 安装并使用aptitude

  4. 醇>

    我的Ubuntu14.04操作系统刚刚安装完成,并进行了软件更新并安装了最新的Nvidia驱动程序。

    你能提供一些帮助吗?提前谢谢!

最佳答案

我今天重新启动了Ubuntu,发现还有另一个未满足的依赖,例如libcog15 : Depends: mesa-driver...(我记不起完整的包名),所以我用apt-get install来安装“mesa-driver”。之后,CUDA 7.5成功安装。

请注意,我的内核版本为3.19.0-28-generic,gcc版本为Ubuntu 4.8.4-2ubuntu1~14.04,在<< a href =“http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#ubuntu-installation”rel =“nofollow noreferrer”> CUDA 7.5官方文件。我会检查它是否真的有效。


相关问答

添加新评论