无法安装python3-dev ubuntu

Modified on: Mon, 25 Jun 2018 11:11:23 +0800

当我尝试使用python3-dev安装sudo apt-get install python3-dev时,我收到以下消息

python3-dev : Depends: libpython3-dev (= 3.4.0-0ubuntu2) but it is not going to be installed
           Depends: python3.4-dev (>= 3.4.0-0~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

所以我尝试安装依赖libpython3-dev然后我收到了这条消息

The following packages have unmet dependencies:
 libpython3.4-dev : Depends: libpython3.4-stdlib (= 3.4.0-2ubuntu1.1) but 3.4.3-1ubuntu1~14.04.1 is to be installed
                    Depends: libpython3.4 (= 3.4.0-2ubuntu1.1) but 3.4.3-1ubuntu1~14.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

但是两个依赖项都已安装。我正在使用Ubuntu 14.04

当我运行apt-cache policy python3.4时,我得到了

    python3.4:
    Installed: 3.4.3-1ubuntu1~14.04.1
  Candidate: 3.4.3-1ubuntu1~14.04.1
  Version table:
 *** 3.4.3-1ubuntu1~14.04.1 0
        100 /var/lib/dpkg/status
     3.4.0-2ubuntu1.1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     3.4.0-2ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

最佳答案

解决方案是等待Ubuntu开发人员将Python 3.4.3重新上载到更新存储库。这应该在任何一天发生。密切关注bug#1348954

编辑:已修复。安装python3-dev再次工作。


相关问答

添加新评论