如何检查Apache在Ubuntu 12.04上使用的OpenSSL版本

Modified on: Mon, 25 Jun 2018 05:30:53 +0800

我在我的机器上安装了Ubuntu12.04,并获得了heartBleed版本的OpenSSL 1.0.1。所以我通过引用这个链接。

现在我要确认Ubuntu 12.04上的“Apache 2.2.22”是使用1.0.1g而不是1.0.1版本的OpenSSL。我该如何确认?

最佳答案

$ apt-cache policy openssl
openssl: Installed: xxx

已安装:xxx ”显示当前安装的openssl版本。 Heartbleed在以下软件包版本(或更高版本)中得到修复:

Ubuntu 13.10:
    libssl1.0.0 1.0.1e-3ubuntu1.2

Ubuntu 12.10:
    libssl1.0.0 1.0.1c-3ubuntu2.7

Ubuntu 12.04 LTS:
    libssl1.0.0 1.0.1-4ubuntu5.12

如果您安装的软件包版本低于这些版本,那么您的系统很容易受到Heartbleed的攻击。

作者:bain

相关问答

添加新评论