VLC不会安装在Ubuntu 15.04中[重复]

Modified on: Sat, 23 Jun 2018 17:20:23 +0800
    

这个问题已经有了答案:

    

    

VLC工作正常,直到我升级到15.04。当我尝试通过软件中心安装时,我收到以下错误消息:

The following packages have unmet dependencies:

 vlc: Depends: vlc-nox (= 2.2.0-1) but 2.2.0+ppa2.4 is to be installed
 Depends: libavcodec-extra-56 (>= 6:11.2) but 6:11.2-1 is to be installed
 Depends: libavutil54 (>= 6:11~beta1) but 6:11.2-1 is to be installed
 Depends: libc6 (>= 2.16) but 2.21-0ubuntu4 is to be installed
 Depends: libegl1-x11 but it is a virtual package
 Depends: libfreetype6 (>= 2.2.1) but 2.5.2-2ubuntu3 is to be installed
 Depends: libgcc1 (>= 1:4.1.1) but 1:5.1~rc1-0ubuntu1 is to be installed
 Depends: libgles1 but it is a virtual package
 Depends: libgles2 but it is a virtual package
 Depends: libqtcore4 (>= 4:4.8.0) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 is to be installed
 Depends: libqtgui4 (>= 4:4.8.0) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu6 is to be installed
 Depends: libstdc++6 (>= 4.9) but 4.9.2-10ubuntu13 is to be installed
 Depends: zlib1g (>= 1:1.2.3.3) but 1:1.2.8.dfsg-2ubuntu1 is to be installed

通过终端:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.0-1) but 2.2.0+ppa2.4 is to be installed
       Recommends: vlc-plugin-notify (= 2.2.0-1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.0-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

当我执行dpkg --get-selections | grep hold似乎没有包裹

当我执行dpkg --get-selections | grep vlc它显示了这个:

libvlc5                     install
libvlccore8                 install
vlc-data                    install
vlc-nox                     install

此外,当我尝试通过终端将其删除时,它表示未安装,因此无法删除。我也尝试了每日发布的videolan ppa同样不幸的结果。
怎样才能让我的旧VLC回来?
谢谢你的帮助!

作者:paulj

最佳答案

问题似乎在vlc-nox中,在升级Ubuntu时不会删除。
如果你最初删除它,一切都应该工作正常。这样的事情:

sudo apt-get remove vlc-nox
sudo apt-get autoremove
sudo apt-get update

然后安装vlc(3.0为我工作):

sudo add-apt-repository ppa:videolan/master-daily
sudo apt-get update
sudo apt-get install vlc

这应该让它发挥作用。 此PPA包含每日更改,可能不稳定或已损坏的开发版本。请参阅PPA说明

  

此PPA包含VLC开发分支的每日构建。


相关问答

添加新评论