错误:确保您的PATH工作正常,或使用--sip参数明确指定工作SIP

Modified on: Sun, 10 Jun 2018 03:35:23 +0800

我想安装官方文档中提到的PyQt5。

以下是他们要求运行的命令的输出:

begueradj@begueradj-hacker:~/Bureau/PyQt-gpl-5.4.1# python configure.py 
Querying qmake about your Qt installation...
Determining the details of your Qt installation...
This is the GPL version of PyQt 5.4.1 (licensed under the GNU General Public
License) for Python 2.7.6 on linux2.

Type 'L' to view the license.
Type 'yes' to accept the terms of the license.
Type 'no' to decline the terms of the license.

Do you accept the terms of the license? yes
Found the license file pyqt-gpl.sip.
Error: Make sure you have a working sip on your PATH or use the --sip argument
to explicitly specify a working sip.

如何解决这个问题?

请注意,我已正确安装SIP:

begueradj@begueradj:~/Bureau/sip-4.16.7# python configure.py 
This is SIP 4.16.7 for Python 2.7.6 on linux2.
The SIP code generator will be installed in /usr/bin.
The sip module will be installed in /usr/lib/python2.7/dist-packages.
The sip.h header file will be installed in /usr/include/python2.7.
The default directory to install .sip files in is /usr/share/sip.
Creating siplib/sip.h...
Creating siplib/siplib.c...
Creating siplib/siplib.sbf...
Creating sipconfig.py...
Creating top level Makefile...
Creating sip code generator Makefile...
Creating sip module Makefile...
作者:,user284234

最佳答案

您需要先安装sip(不只是配置它)

begueradj@begueradj:~/Bureau/sip-4.16.7# python configure.py 
begueradj@begueradj:~/Bureau/sip-4.16.7# make
begueradj@begueradj:~/Bureau/sip-4.16.7# make install

然后你可以安装PyQt:

begueradj@begueradj:~/Bureau/PyQt-gpl-5.4.1# python configure-ng.py

begueradj@begueradj:~/Bureau/PyQt-gpl-5.4.1# python configure-ng.py --sip /usr/bin/sip  
作者:Kantium

相关问答

添加新评论