lspci和lshw没有显示网络设备

Modified on: Sun, 10 Jun 2018 03:12:53 +0800

周末升级到Ocelot。一直都工作正常,直到我今天早上启动计算机。现在我通过集成卡没有有线网络连接。

  • 网络图标显示“没有可用的网络设备”。
  • sudo lshw -C网络不返回任何内容
  • lspci -nn似乎没有显示网络设备
  • 网卡上的指示灯正常闪烁。
  • 在BIOS中启用板载LAN

我尝试了其他地方涉及的建议:

  • service network-manager stop
  • rm /var/lib/NetworkManager/NetworkManager.state
  • service network-manager start

没有运气。

我很擅长使用命令行而不是Linux开发人员,所以我现在已经没有想法了。需要任何想法或其他信息吗?

lspci output:

- 00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
- 00:01.0 PCI bridge: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port (rev 02)
- 00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
- 00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 01)
- 00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 01)
- 00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 01)
- 00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
- 00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
- 00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 01)
- 00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 01)
- 00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev  01)
- 00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 01)
- 00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 01)
- 00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
- 00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
- 00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
- 00:1f.2 IDE interface: Intel Corporation N10/ICH7 Family SATA IDE Controller (rev 01)
- 00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 01)
- 01:00.0 VGA compatible controller: ATI Technologies Inc RV770 LE [Radeon HD 4800 Series]
- 01:00.1 Audio device: ATI Technologies Inc HD48x0 audio
- 07:01.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
- 07:02.0 Communication controller: Conexant Systems, Inc. HSF 56k Data/Fax Modem
- 07:05.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
作者:,caelon

最佳答案

这是你的芯片组,它已经相当成熟了:

http://ark.intel.com/products/27679/ Intel的82801GB-IO控制器

以太网应该在PCI总线上,它没有显示出来
实际上只能归因于固件问题。不管你
在升级过程中故意或某些软件
twiddled端口并关闭BIOS中的控制器。它的
基本上不再存在了。

输入BIOS确保它已打开,即使是,也可以切换它
然后,再次打开,重置为默认值并重新启动。

关闭BIOS的启动启动画面并注意
选项roms loading。你看到一个PXE吗?那会
告诉您以太网是否正常运行。

我怀疑这是一个驱动程序回归,芯片组太旧了。如果
我之前规定的不起作用尝试更改acpi_osi
标记到Windows的早期版本。有时会发生什么
是Linux宣称自己是Windows的新版本
触发BIOS中执行的条件代码。

可能是因为假装是Windows 7会遇到你的错误
固件因此决定不提供以太网
设备。结果与禁用外设无异
BIOS设置。运行时条件代码(ACPI)执行不是很有趣吗?

作者:ppetraki

相关问答

添加新评论